BackupPC – can't find Compress::Zlib

Submit to reddit

It all started with an update for perl by our lovely CentOS. After that backuppc complained about  Compress::Zlib. I tried installing it from CPAN but it didn’t work: Undefined subroutine &Compress::Zlib::gzopen called.

One proposed fix was to remove everything Zlib related from the perl folder in /usr/lib. It did work, as CPAN started working but Zlib refused to install due to errors.

I finally stumbled to this fix:

Turns out it’s a problem with List::Util. The perl-Scalar-List-Utils
rpm conflicts with perl-5.8.8-32.el5_5.1.i386 rpm. Upgrading List::Util
from 1.19 to 1.23 from CPAN solved the problem.

 

Close enough, but my version of List::Util was up to date. Still it was worth a shot; a force install List::Util in perl CPAN shell (perl -MCPAN -e shell) I was back up and running!