digikam 2.6.0 won't start due to missing libavcodec.so.53 (slackware current64)

Submit to reddit

This was pretty simple but complicated :). It turns out I updated ffmpeg from alien bob‘s repo to ffmpeg 0.11, thus upgrading to libavcodec.so.54. I’m sure I could have gotten away with a simple symlink but I wanted a clean install.

So I though I would simply rebuild digikam, right? Wrong. It failed, with weird errors like:

1
make[2]: *** [extra/libkface/test/detect] Error 1

or

1
2
collect2: error: ld returned 1 exit status
make[2]: *** [extra/kipi-plugins/removeredeyes/test/testipp] Error 1

Face detect above sounded a lot like opencv which does depend on ffmpeg, so I rebuild that as well (using the 2.4.1 version since I was at it). Now digikam built successfully.